RB30DET tuning issues

Discuss Nissan tuning topics here. Request definitions, discuss parameters, etc.

Moderators: robertisaar, dex

Post Reply
Posts: 1
Joined: Sat Jun 21, 2014 3:41 pm

RB30DET tuning issues

Post by rbcrisis »

Hi all,
Im a new member here, from NZ, so please be nice haha
my build is

gtr 440cc injectors
stock rb25det turbo
stock 20det afm
front facing plenum
front mount intercooler
90mm throttle body
Im hoping to run a tune of around 400hp-450hp, not wanting a lot just enough.
I may end up trying for more later but for now that figure suits me.

I am having issues with tunerpro rt, romedit, live edit and nistune(trial version).
the issue is I cant get the engine to idle at the k constant that nistune gives me, which is 235 for 440cc(gtr injectors) rb20det stock map with k value changed to 235(00eb) and latency to 76 (4c) . it idles in afrs 12-13 around k value 200-205 but its rough as guts, keeps missing etc, sounding like its lean on lc-1 (i run a vg30e with megasquirt and same lc-1 and it works magic).
Ive checked loads of forums and sites and everyone uses 235 for 440cc injectors. its just not working for me. I also cant rev the engine like it should, it sputters and coughs then revs. i played around with the vq data and scaled it up a bit more and it seemed to fix that but when under load it shoots my lc-1 off scale and the engine begins to die, either too lean or too rich it doesnt tell me.
I tried stock maps through romedit and live edit and they still gave me problems, nistune wasnt much help either. Im now back with the 270cc injectors as it ran mint with those with a chipped rom in a stock rb20det ecun(i didnt drive it as it would have gone way lean but it idled, revved, did everything an engine should). even now it wont work with these injectors. I tried to read the data on the rom chip with moates burn2, and I dont get anything. I was hoping to see how they put their bins together. i have checked all my plugs and they all fire(wasted spark), ive gone through and unplugged an injector at a time to see if it would stumble and nothing has changed. Im using moates ostrich 2 to emulate.

so all in all im stuck. Ive annoyed the neighbors haha, had complaints already, but that wont stop me getting this done.
Any help from you guys would be highly appreciated!
Any bins or xdfs or adrs etc etc ill try them all and see. Im just after a solution! if not Ill buy a chip off trademe(ebays equiv in nz) and try that.
i have probably left out a few things so if your confused just ask me what you need to know.
cheers fellas!!
kind regards
:lol: :lol:

Post Reply